Shopping Basket

 x 

Cart empty


Log In

Find Us Elsewhere

SSL

Forum Search

Keyword

No articles show up when I choose Joomla content

  • oliveira
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
4 years 2 days ago #3150 by oliveira
Hello
No articles show up when I choose Joomla content options in joomla 3.4
K2 categories works good but reather have my website without K2
Anyone have the same problem?

Also is it possible to import a serie Feature Items Pro modules from a Joomla 1.5 to Joomla 3.4 system?

Thank you in advance!

Regards,

Please Log in or Create an account to join the conversation.

More
4 years 2 days ago - 4 years 2 days ago #3152 by boggler
Which version of the module are you using? If you have recently migrated your site from Joomla 1.5 and are using an old version of the module this may be why you are having problems.

Could you provide a screenshot of the settings you are using for the Joomla content? It sounds like you may be using some settings that result in no articles being found. Make sure that there are some Joomla articles in the categories that you select.

Note that if you are selecting articles by category, there must be some articles in the exact categories that you select - just choosing the parent category will not work.
Last edit: 4 years 2 days ago by boggler.

Please Log in or Create an account to join the conversation.

  • oliveira
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
4 years 2 days ago #3155 by oliveira
I am using: Featured Items Pro version 4.0.3
I did an upgrade from 1.5 to 2.5 and then to 3.4

Where can I see my last downloads? I logged in but can't find it.

Please Log in or Create an account to join the conversation.

More
4 years 2 days ago #3156 by boggler
Latest version is 4.0.3, so that should be fine.

As I said, could you post a screenshot of your settings? There is no problem with displaying articles in Joomla categories that I know of so I think it is a problem with your settings.

I am not sure about the answer your question about importing the module from Joomla 1.5 to 3.4, it depends on how you are migrating. If you have a migrator tool that handles modules then it should be fine, I think that SpUpgrade will do this. All that you need is a tool that migrates the module information, then install the latest release of the module on your migrated site.

Please Log in or Create an account to join the conversation.

  • oliveira
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
4 years 2 days ago #3157 by oliveira
Please tell a screenshot from wich settings exactly?
I have 7 tabs with settings do you need them all?


I will send you the main (module tab)

No matter what I select in:
Joomla Content Options
- Category
- Article
I don't see any changes
Attachments:

Please Log in or Create an account to join the conversation.

More
4 years 1 day ago - 4 years 1 day ago #3158 by boggler
Try setting 'use request category' to 'no' - if you have that setting turned on then it will ignore any category settings that you have, and use the current one being viewed.

I don't need all the module tabs, but the Joomla content options tab would have been useful too.

While you are testing the setup I suggest that you should leave the 'category' option completely blank on the Joomla content options tab, and allow the module to select articles from any Joomla category, and select 'all articles' for the article option. On the layout options tab, choose the default layout. If you have any Joomla articles at all on your site, then the module should display something. Once you have got it displaying something then you can start changing the options to what you want.

Also what do you actually see? Do you see the module title, but just empty content? Or nothing at all. If you see nothing at all then your problem is either with the module position or its assignment to Joomla pages. Try assigning it to all pages.

If you see the module title, but just empty content, and you have tried my suggestions above, then there is a problem of some sort with your Joomla content. You might have a problem with the Joomla assets table, which unfortunately can be quite a complicated thing to fix, also check the article creation date is properly defined. Try creating a new test article, and see if it shows up in the module. If it does, then it is definitely a problem with your existing articles.
Last edit: 4 years 1 day ago by boggler.

Please Log in or Create an account to join the conversation.

  • oliveira
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
4 years 1 day ago #3159 by oliveira
Try setting 'use request category' to 'no' >> check/ nothing happend
While you are testing the setup I suggest that you should leave the 'category' option completely blank >> nothing happend :(
On the layout options tab, choose the default layout >> >> check/ nothing happend
Note: Only the title of the modules is visible on the website but no content/ articles

I have a lot of articles to be displayed, at this moment I have 14 Featured Items Pro 'Modules waiting to be displayed but ity only works in K2, not in Joomla content (wich I need badly, because I have to import 59 Featured Items Pro 'Modules from the old website ;-(

Yes I see the module title
The module position works fine

also check the article creation date is properly defined. >> check/ nothing happend

Please Log in or Create an account to join the conversation.

More
4 years 1 day ago - 4 years 1 day ago #3160 by boggler
Try creating a new test article and see if it shows up - I think that there has to be a problem somewhere with your existing Joomla articles.

Also check the viewing permissions for the articles - the module does check the viewer's access to the articles, the viewer must have the permission to view both the article and the category it belongs to, so if you are viewing the site as a 'guest' user then these must be visible to guests.

The module has been tested with your version of Joomla, I tested it again myself today, there is no problem that I can find with displaying Joomla articles, so this is something to do with your site.
Last edit: 4 years 1 day ago by boggler.

Please Log in or Create an account to join the conversation.

  • oliveira
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
4 years 1 day ago #3161 by oliveira
Oke I find out what the problem is.
All imported articles (from Joomla 1.5 to 3.4) have no author (for some reason it is missing on all articles :-(
Do you know a quick way to add an author to all articles in one time? This would fix everthing.

Please Log in or Create an account to join the conversation.

More
4 years 1 day ago #3162 by boggler
I will email you a possible solution, when I tried to post it here my firewall thought it was an attempt to hack my own site and blocked it.

Please Log in or Create an account to join the conversation.

Moderators: boggler
Time to create page: 0.883 seconds

Donate to Us

If you like our extensions, consider making a donation to say thanks.