Shopping Basket

 x 

Cart empty


Log In

Find Us Elsewhere

SSL

Forum Search

Keyword

Parse error on install

  • Champenois
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
4 months 1 week ago #8016 by Champenois
Parse error on install was created by Champenois
Greetings, I had hoped to wake up to a reply to a support email (my original purchase email said reply to this email if you need support). Unfortunately, nothing there.With a possibility it has not reached the intended target, I'll copy it here, thank you
We're just in the process of swapping our website over to a better choice of domain name.

We've tried reinstalling your amazon shoppingcart package but it won't install, installer says "parseerror"
We've unzipped the package and it will install com_amazonws.zip and plg_amazonws.zip.
The other items in the package return install "parseerror", see attached pic.

We believe we still have ~6 months of the current sub. and we've changed the domain name on your site to the replacement.
Can't see a licence setup between your site and ours.
Joomla operating as expected with everything else.
Apart from that I can see nothing in your installation instructions that would give a clue.
Any ideas what's going wrong?

Joomla 3.8.7, php 7.1
Package files just downloaded from your website under our purchase, it says v.1.7.0
Attachments:

Please Log in or Create an account to join the conversation.

More
4 months 1 week ago #8017 by boggler
Replied by boggler on topic Parse error on install
Hello, actually I did reply to your email yesterday, unfortunately gmail returned it due to the attachment.

You should get the email now, I have resent it minus the attachment.

But actually I think that this is a Joomla issue, so far as I know it does not fully support PHP 7.1, so possibly this is causing an issue with the installer. If you can drop PHP down to 7.0 then you should find that it installs without problems.

There is nothing in the extension which restricts the license, so that is definitely not the issue. And I have been doing a lot of testing with the extension in preparation for our new release, which involved a lot of installation, uninstallation and re-installation, and did not find any issues with the extension. But that was in 7.0, as Joomla does not fully support 7.1.

A more efficient way to move the site would be to just copy the database and files, just a quick edit to the configuration.php is all that is required. It should not be necessary to reinstall the extension.

Please Log in or Create an account to join the conversation.

  • Champenois
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
4 months 1 week ago #8018 by Champenois
Replied by Champenois on topic Parse error on install
I have replied by email to you Fiona.

Also please provide the links/info you found where you state that Joomla does not support php 7.1

Thank you, John

Please Log in or Create an account to join the conversation.

More
4 months 1 week ago #8019 by boggler
Replied by boggler on topic Parse error on install
Actually I don't think there is an issue with the latest release of Joomla running PHP 7.1, I just know that there were some in the past. Unfortunately the official information about technical requirements is fairly vague, it just says PHP 7.0+ https://downloads.joomla.org/technical-requirements

But anyway I just ran a quick test running PHP 7.1, and there is no problem either with Joomla or installing the Amazon Shopping Cart.

But what I do notice is that the screen shot of the error message you are sending me. That is "www.*****.support say: parsererror".

That is not generated by Joomla or the Amazon Shopping Cart, it seems to be a 3rd party extension. It is possible that this extension is not fully PHP 7.1 compatible. Try disabling that, and just use the Joomla installer. Disable any non-core installation plugins.

You should find that it installs without issue then. There are no known issues with installing using the Joomla installer.

Please Log in or Create an account to join the conversation.

Moderators: boggler
Time to create page: 0.468 seconds

Donate to Us

If you like our extensions, consider making a donation to say thanks.