Shopping Basket

 x 

Cart empty


Log In

Find Us Elsewhere

SSL

Forum Search

Keyword

Error message When Attempting to Access Amazon S3 Bucketts

  • murphylas
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
4 months 2 days ago #7943 by murphylas
I just installed the as3manager extension. I added my Amazon S3 credentials successfully. However, when I try to view the buckets, I get the following errors:

Note: I already have akeeba release system which accesses Amazon S3 installed on this site.

Warning: require(): Unable to find the wrapper "phar" - did you forget to enable it when you configured PHP? in /home/themannatest/test.themannareserve.org/components/com_amazons3/aws/aws_2.8.19.phar on line 3

Warning: require(): Unable to find the wrapper "phar" - did you forget to enable it when you configured PHP? in /home/themannatest/test.themannareserve.org/components/com_amazons3/aws/aws_2.8.19.phar on line 3

Warning: require(phar://aws.phar/aws-autoloader.php): failed to open stream: No such file or directory in /home/themannatest/test.themannareserve.org/components/com_amazons3/aws/aws_2.8.19.phar on line 3

Fatal error: require(): Failed opening required 'phar://aws.phar/aws-autoloader.php' (include_path='.:') in /home/themannatest/test.themannareserve.org/components/com_amazons3/aws/aws_2.8.19.phar on line 3

Please Log in or Create an account to join the conversation.

More
4 months 1 day ago #7944 by boggler
This seems to be an issue with your PHP configuration, it is unable to open the PHP archive (phar) file which contains the Amazon SDK.


Which version of PHP are you using? Are you testing on localhost? If not I suggest contacting your web host.

It might be that the SDK is incompatible with the version of PHP that you are using, if you let us know what that is we will investigate.

Please Log in or Create an account to join the conversation.

More
4 months 1 day ago #7945 by boggler
The phar:// stream wrapper which this error message concerns has been available since PHP 5.3, if you are using a version of PHP lower than this you really should not be.

The latest release of Joomla requires PHP 5.6, and Joomla 4 will require version PHP version 7.

Please Log in or Create an account to join the conversation.

  • murphylas
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
4 months 1 day ago #7946 by murphylas
I am running on a webhost. No localhost. My configuration data is:

Database Type mysql
Database Version 5.6.34-log
Database Collation utf8_general_ci
Database Connection Collation utf8mb4_general_ci
PHP Version 7.0.28
Web Server Apache
WebServer to PHP Interface cgi-fcgi
Joomla! Version Joomla! 3.8.6 Stable [ Amani ] 13-March-2018 14:00 GMT
Joomla! Platform Version Joomla Platform 13.1.0 Stable [ Curiosity ] 24-Apr-2013 00:00 GMT

Please Log in or Create an account to join the conversation.

More
4 months 1 day ago #7947 by boggler
OK, thanks for the information. Your versions are fine, the extension has been tested with PHP 7 and there is no issue that we can find.

I think that this has to be an issue with your PHP configuration, the only solution that I can see is to ask your webhost to enable the phar:// wrapper. Hopefully they will do so.

Otherwise I don't think that there is any change that we could make to the extension that would enable this for you. Sorry about that, it is just not something we can fix.

Please Log in or Create an account to join the conversation.

  • murphylas
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
3 months 4 weeks ago #7948 by murphylas
Your response does not make sense.

I am using the Akeeba Release System and the JCE Editor. Both of these extensions use Amazon S3. They work perfectly. They do not kick out strange error messages about missing software.

Also, the Akeeba Release System is used by Joomla.org to distribute Joomla itself.

The problem is with your software. This needs to be fixed.

I also do NOT see a working example of this extension on your demo site.

Please Log in or Create an account to join the conversation.

More
3 months 4 weeks ago - 3 months 4 weeks ago #7949 by boggler
Why does my reply not make sense? I have looked into this carefully. The error message you reported says:

Warning: require(): Unable to find the wrapper "phar" - did you forget to enable it when you configured PHP? in /home/themannatest/test.themannareserve.org/components/com_amazons3/aws/aws_2.8.19.phar


  1. It clearly says that it is an issue with the PHP configuration.
  2. the file that is throwing the error is this one: aws_2.8.19.phar . This is the Amazon Web Services sdk, distributed by Amazon, not us
  3. Presumably the other extension you mention do not use the AWS SDK, that is why they don't have the same error.
  4. yes it needs to be fixed, but not by us, by your web host
Last edit: 3 months 4 weeks ago by boggler.

Please Log in or Create an account to join the conversation.

Moderators: boggler
Time to create page: 0.267 seconds

Donate to Us

If you like our extensions, consider making a donation to say thanks.