Shopping Basket

 x 

Cart empty


Log In

Find Us Elsewhere

SSL

Forum Search

Keyword

Can't get feed to work

  • comenaranjas
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
3 years 9 months ago - 3 years 9 months ago #3479 by comenaranjas
Can't get feed to work was created by comenaranjas
Hi

Im getting 2 warnings in my feed at google merchant center.

support.google.com/merchants/answer/6101155?hl=en-GB
and support.google.com/merchants/answer/6101167?hl=en-GB

My feed says products are processed but in product tab it shows no products with message "there are no offers to show"

BTW products with marked price below 1.00 are ignored by the feed. Products with prices like 0.90 € or 0.xxx are not processed.

Regards
Last edit: 3 years 9 months ago by comenaranjas.

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago #3483 by boggler
Replied by boggler on topic Can't get feed to work
Hello, sorry for the delay in response.

I don't think that the first issue is to do with your feed, but is due to the micro-data on your site. If you use certain additional markup on your product landing pages to tell Google what the price is it can update it automatically, but I don't think Virtuemart supports it. It requires some modifications to your site template.

Hard to be sure though, as normal with Google it is quite vague so could mean almost anything.

I will check into the problem with prices under 1.0, it sounds like a rounding error somewhere.

Please Log in or Create an account to join the conversation.

  • comenaranjas
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
3 years 9 months ago #3486 by comenaranjas
Replied by comenaranjas on topic Can't get feed to work
Microdata is included in VM3 for a few versions already, it is part of the core and my template displays rich snippets.
Actually since 3.0.10 virtuemart.net/news/latest-news/472-release-of-3-0-10

Regards

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago #3489 by boggler
Replied by boggler on topic Can't get feed to work
Nevertheless the warning message appears to be about a problem with the microdata on your landing page, not about the feed.

I am sorry, but unless you can show me that this is a problem where the feed is showing incorrect data then it is not something that I can fix for you.

We do have a fix for the problem with items under 1.0 not being displayed, we will release a new version with the fix shortly.

My feed says products are processed but in product tab it shows no products with message "there are no offers to show"


This may simply be a matter of waiting. If you have recently submitted the feed then it does take time for the offers to appear, your site has to undergo various reviews to ensure that it complies with Google's policies. After it has been automatically processed it will undergo a manual review. If nothing happens, you will need to contact Google to find out why.

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago #3490 by boggler
Replied by boggler on topic Can't get feed to work
For your further information, the extent to which Virtuemart supports micro-data is extremely limited, and not adequate for Google to do automatic updates. What they require is this: https://developers.google.com/structured-data/rich-snippets/products , that is, detailed structured information about the prices, currency etc as displayed in the example.

The only thing that Virtuemart includes is a snippet for the product name:-
<h1 itemprop="name"><?php echo $this->product->product_name ?></h1>

That I think is why Google is complaining.

Please Log in or Create an account to join the conversation.

  • comenaranjas
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
3 years 8 months ago - 3 years 8 months ago #3510 by comenaranjas
Replied by comenaranjas on topic Can't get feed to work
My rich snippets are displayed with price, reviews, global rating and availability which is the minimum required by google, and currency yes.

Furthermore google has a data testing tool for microdata where my product links are marked as fine.

As mentioned this appear in google search results so if this was limited or incorrect I doubt it would be displayed in the search.

But nevermind.
Last edit: 3 years 8 months ago by comenaranjas.

Please Log in or Create an account to join the conversation.

More
3 years 8 months ago - 3 years 8 months ago #3512 by boggler
Replied by boggler on topic Can't get feed to work
I think that the microdata that Google require to automatically update the price based on information on your landing page is more detailed than that required for appearing in Google search results. Testing that the link is fine tells you nothing really, other than that the link is fine.

If you know of any information that the feed is missing then do let me know and I will see that it is fixed, we are always looking to improve it, and study the Google product feed specification carefully to make sure that the information structure is up to date. I am still of the opinion that the message you are getting is not about the feed.

Even if Google cannot update the price from your landing page, you can schedule your feed to be fetched daily, so it can be updated quite quickly.

As I said, we are always looking to improve the feed, so if you know of any feature that it could usefully have then we will certainly look at adding it.
Last edit: 3 years 8 months ago by boggler.

Please Log in or Create an account to join the conversation.

  • comenaranjas
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
3 years 7 months ago - 3 years 7 months ago #3558 by comenaranjas
Replied by comenaranjas on topic Can't get feed to work
Hello Fiona

Finally I had time to test this in more depth so here are my conclusions.

You were right in your point, our template has "basic" rich snippets but looking at the source code of the landing pages for products it doesn't contain the code for availability or condition, something required by google.

So for anyone having this problem the easy solution is to disable microdata in google merchant center. You scroll down to options and disable automatic item updates.

Of course this won't show the rating reviews and count of reviews but the feed will be published.

Our only issue remaining is that we have a warning in google merchant center telling us to please add the GTIN (really strange since we sell fruits).

We had the option "Use identifier exists" set to Yes and now we have tried setting "Use SKU as GTIN" to Yes.
We still get the message but I have changed it just today so ill wait till tomorrow although we have resend the feed.


Regards
Last edit: 3 years 7 months ago by comenaranjas.

Please Log in or Create an account to join the conversation.

More
3 years 7 months ago #3561 by boggler
Replied by boggler on topic Can't get feed to work
Thanks for updating us on this.

You should not use the "Use SKU as GTIN" option unless the SKU really is a valid GTIN, which is sounds like yours is not.

You should definitely set the "Use identifier exists" set to Yes. What this option does is to include an identifier_exists tag with a value of FALSE in the feed, if there is no GTIN or MPN (manufactuer part number).

I think that should work for you, because I assume that fruit does not have an MPN either.

Please Log in or Create an account to join the conversation.

Moderators: boggler
Time to create page: 0.246 seconds

Donate to Us

If you like our extensions, consider making a donation to say thanks.