Shopping Basket

 x 

Cart empty


Log In

Find Us Elsewhere

SSL

Forum Search

Keyword

GOOGLE XML IMAGE NOT UPLOADED

More
4 years 10 months ago #2973 by boggler
Replied by boggler on topic GOOGLE XML IMAGE NOT UPLOADED
There is nothing wrong with the images in your feed. If you view the feed in your web browser you will not see them because it is not a web page it is an xml feed and they are not normal image tags.

However if you right click on the page and view the xml source you will see that it contains the correct image tags as it should, for example
<g:image_link>http://www.dpieces.fr/images/stories/virtuemart/product/c00076445.jpg</g:image_link>

If you check the image url you will see that the image loads as it should.

Your robots.txt file is fine, but, if Google has recently asked you to change it so that they can crawl your images folder, you need to be aware that it takes them some time to do this, it can take up to a week, there is no alternative but to wait unfortunately. There is no other problem with your images.

Please Log in or Create an account to join the conversation.

More
4 years 10 months ago #2974 by boggler
Replied by boggler on topic GOOGLE XML IMAGE NOT UPLOADED
The following user(s) said Thank You: dpieces

Please Log in or Create an account to join the conversation.

More
4 years 7 months ago - 4 years 7 months ago #3032 by mike01227
Replied by mike01227 on topic GOOGLE XML IMAGE NOT UPLOADED
I really cannot figure out why the products images are not in the feed, even when i turn the developer tools on.

I've tried everything and read everything. please help

www.brotoolsdirect.co.uk/index.php?optio...exml&format=xml&id=1

Thanks
Last edit: 4 years 7 months ago by mike01227.

Please Log in or Create an account to join the conversation.

More
4 years 7 months ago #3033 by boggler
Replied by boggler on topic GOOGLE XML IMAGE NOT UPLOADED
Hello, in the advanced options tab, turn off the option 'Include mime check?'. It think it is likely that this is what is causing the problem.
Make sure that the images are not marked as 'for sale' in the media manager. If that does not solve the problem please turn on the 'debug component' option and let me know, this will put some extra information in the product feed which may help me see what is happening.



Also on the advanced tab, change the Base URL parameter to

www.brotoolsdirect.co.uk/

note the '/' at the end. Or you can probably leave it blank. At the moment it is causing problems for your product links.

Please Log in or Create an account to join the conversation.

More
4 years 7 months ago #3034 by mike01227
Replied by mike01227 on topic GOOGLE XML IMAGE NOT UPLOADED
Hi,

The mime check is off, it's always been off.

I searched the joomla and virtuemart media areas and cannot find any Images "for sale" options

I have now also forced my ssl and changed the Base URL parameter to www.brotoolsdirect.co.uk i have also tried it without the https

Still no luck, i have turned on the debug

www.brotoolsdirect.co.uk/index.php?optio...exml&format=xml&id=1

Thanks
Attachments:

Please Log in or Create an account to join the conversation.

More
4 years 7 months ago #3035 by boggler
Replied by boggler on topic GOOGLE XML IMAGE NOT UPLOADED
I am very puzzled by this - the image file urls are not being picked up from the database. This should be pretty foolproof because the feed uses Virtuemart's own code to get these..

Can you give me an admin login to your site? I think it would be best if I take a look myself and see what is going on. Don't post them here, please send them to the address from which you received your order confirmation, ie customers at spiral scripts.

Please Log in or Create an account to join the conversation.

More
4 years 7 months ago #3036 by boggler
Replied by boggler on topic GOOGLE XML IMAGE NOT UPLOADED
I should add, to explain about the for sale option:-

If you find the image file in the Virtuemart media manager, it should have 'displayable' rather than downloadable in the role option, and the storage/location type of 'product'. It should not be marked 'for sale'. I would guess that it is somewhere among these details that the problem lies, and is preventing the feed from correctly picking up the image.

However it is probably still best if I just take a look.

Also you are still missing the '/' off the end of the base url for your site - note that this is the option in the advanced options tabe.

Please Log in or Create an account to join the conversation.

More
4 years 7 months ago #3037 by mike01227
Replied by mike01227 on topic GOOGLE XML IMAGE NOT UPLOADED
Hi,

I have sent the login credentials

Thanks

Please Log in or Create an account to join the conversation.

Moderators: boggler
Time to create page: 0.493 seconds

Donate to Us

If you like our extensions, consider making a donation to say thanks.