Shopping Basket

 x 

Cart empty


Log In

Find Us Elsewhere

SSL

Forum Search

Keyword

VM Mod Controller not show on manufacturer page

  • Yannos31
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
8 years 2 months ago - 8 years 2 months ago #120 by Yannos31
Hello,

At first thanks for your module which is so useful for virtuemart.

I only have one problem with the shop.manufacturer_page where the module isn't display.
All others pages i need work well.

i think it could come from the link i use to open the page.
Links are generate by mod_virtuemart_manufacturers_1.1.0 and look like that
index.php?option=com_virtuemart&page=shop.browse&manufacturer_id=3&Itemid=2&lang=fr

Can you help me please to find a solution.

Thanks

My config
Joomla 1.5.23
Virtuemart 1.1.8
Last edit: 8 years 2 months ago by Yannos31.

Please Log in or Create an account to join the conversation.

More
8 years 2 months ago #121 by boggler
The page you show the link for is page 'shop.browse' not 'shop.manufacturer_page', if you want the module to display on that page you will need to set the VM Page parameter to 'shop.browse'.

Please Log in or Create an account to join the conversation.

  • Yannos31
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
8 years 2 months ago #122 by Yannos31
Thanks for quick answer

It is already set on shop.browse
I also use categories filter
Other setting aren't use

Attachment ss_pb_vm.JPG not found

Attachments:

Please Log in or Create an account to join the conversation.

More
8 years 2 months ago #123 by boggler
It's because you are filtering by category as well - the url

index.php?option=com_virtuemart&page=shop.browse&manufacturer_id=3&Itemid=2&lang=fr

does not include a category id. If you filter by category only urls that include a category id that matches the category filter will display the module

Please Log in or Create an account to join the conversation.

  • Yannos31
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
8 years 2 months ago - 8 years 2 months ago #124 by Yannos31
Ok i understand,
And do you see an other way for get my module display on my link ?

Thanks
Last edit: 8 years 2 months ago by Yannos31.

Please Log in or Create an account to join the conversation.

More
8 years 2 months ago #125 by boggler
Could you explain a bit more clearly what you are trying to do? Are you trying to display a module for one particular manufacturer? Different modules for different manufacturer pages? Or do you just want it to display when a browse page for any manufacturer is being viewed.

At the moment there are no options for filtering by manufacturer, but it is an option we could think about adding.
The following user(s) said Thank You: Yannos31

Please Log in or Create an account to join the conversation.

  • Yannos31
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
8 years 2 months ago - 8 years 2 months ago #127 by Yannos31
Ok sorry,
my english is a little poor :unsure:

In my situation i think a display for shop.browse&'any manufactrer' could be enough.

Attachment ss1.JPG not found



Attachment ss2.JPG not found



A second module for woman categorise should be display on shop.browse.manufaturer

Hope it is understandable
thanks for interest.
Attachments:
Last edit: 8 years 2 months ago by Yannos31.

Please Log in or Create an account to join the conversation.

  • Yannos31
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
8 years 2 months ago #129 by Yannos31
Don't loose time with this problem i have find an other way.

i will stop to use virtuemart manufactured system and creat manufacturer like a category.
Like that VM Mod Controller can display all module like i want.

Thanks a lot for support

Please Log in or Create an account to join the conversation.

More
8 years 2 months ago #130 by boggler
OK, I can think about this and whether this can be done.

Please Log in or Create an account to join the conversation.

More
8 years 2 months ago - 8 years 2 months ago #132 by boggler
I think that if that is all that you want to do then the easiest thing is to modify the code directly. You will need to edit the module file helper.php

add the lines

[code type=php-brief]$manufacturer = JRequest::getVar('manufacturer_id', null);
if(isset($manufacturer))
{
$renderModule = true;
}
[/code]

You will need to put them on line 287, immediately before the line

[code type=php-brief]return $renderModule;[/code]


The effect of this will be to check whether a manufacturer id is being set, and render the module output if this is the case.

If you do this, it will apply to all instances of the module, so if you want to use it in other ways then this won't be useful.
Last edit: 8 years 2 months ago by boggler.
The following user(s) said Thank You: Yannos31

Please Log in or Create an account to join the conversation.

  • Yannos31
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
8 years 2 months ago #134 by Yannos31
So nice :woohoo:

Exactly what i wanted

Thanks again

Please Log in or Create an account to join the conversation.

  • Yannos31
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
8 years 2 months ago #158 by Yannos31
Hi, it's me again

i have another problem,
I starting to use artio joomsef for url rewriting

Vm controller work well on category page and manufacturer page, but failed to filter module display on product page?

Any idea ?
Do you want i open a new post ?

Please Log in or Create an account to join the conversation.

Moderators: boggler
Time to create page: 0.420 seconds

Donate to Us

If you like our extensions, consider making a donation to say thanks.